Content

Recommended software

Operating systems support by the University

Desktop Operating Systems  Comments 
Windows 7 Enterprise#
English language version 
 
  • USQ Preferred Operating System
  • Pre-requisite if enrolled in Faculty of Business courses that use Java, Oracle or .NET
  • Support is limited to connectivity issues with USQ
  • Must be fully patched and have all the latest upgrades available from the manufacturer (Note USQ is currently using Service Pack 1)
  • Issues regarding software compatibility and peripheral hardware are the owner's responsibility
  • Note: the USQ Bookshop is able to sell versions of Windows 7 at significant discounts off RRP pricing to registered students. 
Windows XP all other editions#
English language version 
 
  • Support is limited to connectivity issues with USQ
  • Must be fully patched and have all the latest upgrades available from the manufacturer
  • Issues regarding software compatibility and peripheral hardware are the owner's responsibility
  • Note that this Operating System is not intended for business use.  
Windows 8 
  • Limited support for connectivity issues with USQ
  • Issues regarding software compatibility and peripheral hardware are the owner's responsibility

Mac System OS X 10.5 or greater 

 

 

 

  • Mac System OS X 10.5 or greater 



 IOS
  •  Support is limited to connectivity issues with USQ 
Linux 
  • Linux is not currently widely used or supported across the University. It is supported for students in the Faculty of Sciences Department of Mathematics and Computing by Department staff. 
Android (BYOD) 
  •  Support is limited to connectivity issues with USQ

# Windows 7 operating systems treat IT security issues very seriously. Owners should be aware that connectivity with USQ may require some modification to security settings. Individuals whose computer connection to USQ originates behind a government, corporate or personal firewall (security software) may face special configuration issues, which may require the permission of relevant IT support to modify. USQ cannot take responsibility for an individual's failure to achieve connectivity from behind a firewall.

Operating systems unsupported by the University

Desktop Operating Systems   Comments 
Mac System less than OS X 10.5 
  • May not be fully compatible with USQ IT systems and/or IT security requirements 
Windows Vista 
  • Not supported by USQ 
Windows 95, 98 and 98 SE, Windows XP 
  • No longer supported by Microsoft  
  • Might be compatible with USQ IT systems and/or IT security
  • Many people use Win 98 Second Edition successfully but it is not supported.
Windows Me
(Millennium Edition) 
 
  • May not be compatible with USQ IT systems and/or IT security requirements. 
Windows NT4 Workstation 
  • No longer supported by Microsoft  
  • Might be compatible with USQ IT systems and/or IT security requirements but it is not supported.

If you require further information on recommended hardware please contact the ICT Service Desk.